sageman's 'barn find' v6 sei s1

The place to show off and tell us all about your XMs (or even other cars). Should it be a big project, or just some general pics, start your thread in here.
User avatar
Dean
Global Moderator
Posts: 5999
Joined: Wed Apr 15, 2009 7:53 am
Location: Isle of wight

Re: sageman's 'barn find' v6 sei s1

Post by Dean » Thu Dec 06, 2018 1:10 pm

So if we assume you have fuel as the plugs are smothered in the stuff, if you have a spark in the right place too then there could well be a mechanical problem, quick compression test while the plugs are out to just confirm that's all fine?

D
92 Citroen XM Prestige 3.0i Auto R.P5678
14 Mitsubishi L200 Trojan
89 Talbot Express motorhome Auto-Trail coachbuilt (looking for bonnet, wings, scuttle panels etc)

Addicted to Crackanory

User avatar
sageman
Knows how to use the parking brake
Posts: 117
Joined: Sat Sep 16, 2017 5:07 pm
Location: norwich

Re: sageman's 'barn find' v6 sei s1

Post by sageman » Thu Dec 06, 2018 3:08 pm

Haven’t got any compression test gear

Had the AA out he don’t know either so I’ve got a lorry on its way to take it where I’m storing it until we get the new house next year
1976 Reliant kitten
1985 Reliant fox Tandy campervan
1998 Peugeot 306 GTI-6
h̶o̶p̶e̶f̶u̶l̶l̶y̶ ̶a̶n̶ ̶X̶M̶ ̶o̶n̶e̶ ̶d̶a̶y̶
1993 XM sei V6

User avatar
sageman
Knows how to use the parking brake
Posts: 117
Joined: Sat Sep 16, 2017 5:07 pm
Location: norwich

Re: sageman's 'barn find' v6 sei s1

Post by sageman » Mon Jan 07, 2019 10:17 pm

ive now got it started again i think it might be overfueling so yes i think i need to get ahold of a lexia one way or another and learn how to rewire comnnectors
when attempting to get it started before Christmas i made the rarther nasty discovery that many more connectors have some sort of damage than i previosly thought

all spheres excluding the rear spheres have been changed havnt tried rear centre yet but i cant get the other two off followed whats in the book but dont want to hit them too hard and brake something.... any tips or ideas

ive also discovered another leak
its drivers side (RHD) behind the wheel arch and far as i can tell theres only two pipes there the main suspension pipe and another pipe but i cant tell which one is leaking theyre both covored in oil and both drip
leak is quite fast but its not all the time strangly (i think)

i also cant tell where its coming from due to where the pipes are theres no acsess

Image
not a particualy good picture i know
the large pipe is (i belive) from the strut top so i assume its the main suspension pipe the smaller one i cant renember where it goes but it looks like its heading to the wheel in my picture could this be a leakoff pipe giving the slow leak (which is coming from further up those two pipes) or is it possable for high pressure pipes to leak slowly sometimes
1976 Reliant kitten
1985 Reliant fox Tandy campervan
1998 Peugeot 306 GTI-6
h̶o̶p̶e̶f̶u̶l̶l̶y̶ ̶a̶n̶ ̶X̶M̶ ̶o̶n̶e̶ ̶d̶a̶y̶
1993 XM sei V6

User avatar
White Exec
Citroen God!
Posts: 5047
Joined: Fri Mar 11, 2011 7:38 pm
Orga / RP numbers: RP7165
1996 2.5TD saloon, manual, Polar White
Location: ex-Ealing, Cheshire, W.Sussex & Surrey. Now living in Sayalonga (Malaga, Spain)

Re: sageman's 'barn find' v6 sei s1

Post by White Exec » Mon Jan 07, 2019 11:21 pm

You'll need to clean up the area and dry off, then a better chance of seeing where the leak is. It's usually from the small leak-back pipes, and their rubber couplings.
Chris
1996 XM 2.5TD Exclusive RP7165 Polar White
2003 RAV4 D4D 2.0 5dr LHD Silver WORKHORSE
1989 BX19RD Delage Red Deceased; 1998 ZX 1.9D Avantage auto Triton Green Company car 1998-2001; 2001 Xantia 1.8i auto Wicked Red Company car 2001-2003

User avatar
MTXM
Citroen God!
Posts: 4856
Joined: Mon Apr 20, 2009 8:45 pm
Location: Aylsham Norfolk

Re: sageman's 'barn find' v6 sei s1

Post by MTXM » Tue Jan 08, 2019 11:03 am

I was sorry to hear about the further issues Ben and including hydraulic leaks and the advice from Chris to thoroughly clean the effected area does make great sense. It is not uncommon for the large diameter low pressure return pipes behind the front wheels to weep at the rubber-metal unions and I suspect that is your problem. The access to replace the pipes is unfortunately very restricted, but the job is doable and I replaced an offside pipe one of my V6. In relation to removal of the tight spheres I strongly recommend the careful application of heat and I have not been beaten yet! With regards, Matthew T.
1989 V6 Exclusive (Poland car)
1990 V6sei auto (grey auto)
1990 V6sei manual (gold car)
1990 V6.24 Pallas (Germany car)
1990 V6.24v (Scotland car)
Other previous XM sold and broken too many to mention!

User avatar
White Exec
Citroen God!
Posts: 5047
Joined: Fri Mar 11, 2011 7:38 pm
Orga / RP numbers: RP7165
1996 2.5TD saloon, manual, Polar White
Location: ex-Ealing, Cheshire, W.Sussex & Surrey. Now living in Sayalonga (Malaga, Spain)

Re: sageman's 'barn find' v6 sei s1

Post by White Exec » Tue Jan 08, 2019 3:59 pm

For all spheres except the rear corner ones*, make sure the system is depressurised (and on lowest, etc) when trying to unscrew. Pressure tightens a sphere in its mount, which is why they only need to be done up hand-tight when replacing.

* Rear corners: leave system pressurized (car on highest and well supported) while you slacken these off by just a quarter of a turn. Then depressurize and unscrew.
Last edited by White Exec on Thu May 16, 2019 8:24 pm, edited 1 time in total.
Chris
1996 XM 2.5TD Exclusive RP7165 Polar White
2003 RAV4 D4D 2.0 5dr LHD Silver WORKHORSE
1989 BX19RD Delage Red Deceased; 1998 ZX 1.9D Avantage auto Triton Green Company car 1998-2001; 2001 Xantia 1.8i auto Wicked Red Company car 2001-2003

User avatar
sageman
Knows how to use the parking brake
Posts: 117
Joined: Sat Sep 16, 2017 5:07 pm
Location: norwich

Re: sageman's 'barn find' v6 sei s1

Post by sageman » Thu May 16, 2019 4:37 pm

ok time to get back to this now ive got some...time

built a blink tester it gave out several codes which was to be expected as i had gone around unplugging and cleaning various sensors contacts the only one of note was
27 vechel speed sensor as i had the battery disconnected for a while when i replaced the battery terminals (clearing the computer) i haven't moved the car at all since
and strangely missing was any ICV code also something i had disconnected in the past

since replacing the terminals i no longer get the random up and down revving i had before (i also discovered this was ICV unrelated as on one occasion it did it with ICV disconnected)
now two things happen

cold: idle seems ok if perhaps a little high but when the throttle is blipped it comes back to idle in stages
hot: blip the throttle and the rpm stays at its maximum where you blipped it to press a little further the rpm increases more it looks as if it tries to come back down but cant
_or it goes instantly to 2500-3000rpm after starting despite ICV manualy closed beforehand and plugged in

now the only original code that wold have a major effect on this situation was
23 (TPS) Throttle spindle potentiometer idle value 0,5 +/- 0,1V between pin 9 and 17 (gnd)

i cleared codes started the car for a muinite or two blipping the throttle several times to different rpms stopped the engine
no codes

so i unplugged the TPS and the ICV started for a muinite stopped again resulting only in 23 again (presumably this is why it was up before)

plugged in again cleared codes started engine
now this time while idling i did something i havnt done before (i dont think) that is blipping throttle flat down (not allowing rpm to increase to red line though)
car idled as it had been doing that day (cold) (revs came back in stages)
i left car idling for a while then it decided to act as it does (hot) over the space of about 20 seconds it went from its normal idle to 2500 and again when blipping throttle rpms icrese higher and higher i stop engine and get code

21 4,5V max swing on pin 9
not something i had the first time round
i then found this (bottom of page)
viewtopic.php?f=19&t=6664&hilit=v6+thro ... &start=280

so i think tomorrow i will be looking into this further see if i can get any resistance readings and think of a way to get voltage
1976 Reliant kitten
1985 Reliant fox Tandy campervan
1998 Peugeot 306 GTI-6
h̶o̶p̶e̶f̶u̶l̶l̶y̶ ̶a̶n̶ ̶X̶M̶ ̶o̶n̶e̶ ̶d̶a̶y̶
1993 XM sei V6

Dieselman
Global Moderator
Posts: 10838
Joined: Thu Jun 18, 2009 6:44 pm

Re: sageman's 'barn find' v6 sei s1

Post by Dieselman » Thu May 16, 2019 7:02 pm

I wouldn't get too hooked up on the throttle pot voltage readings, as long as it is close to spec the ECU will work fine.
The throttle pot is there to ensure the ECU knows when throttle closed is required, after that it responds to throttle opening by richening the mixture before the Lambda sensor takes over in closed loop.

I suspect you have a vacuum leak.

1. Ensure the throttle plate has a good spring return action.

2. Check for vacuum leaks. If you don't have a vacuum guage and smoke tester, run the engine at idle and block the idle bypass hose. The engine should either stall or idle below 500Rpm. Spray around with carb cleaner/brake cleaner or propane through a small nozzle to see if you have a leak.

3. Unplug the Lambda sensor to force Open Loop running. This means the ECU wiill run in it's default state with no correction/interference from the lambda sensor, which aids diagnostics as any poor running is not a result of the Lambda sensor adjusting the mixture strength.

My v6-24 can't attain TPS values of 0.5v closed and >4.5v WOT. The maximum is about 4.38v.

The throttle and the idle bypass valve control engine revs. Nothing else should be able to, even a varying mixture strength won't alter the revs.

If the revs are rising, there must be air entering the intake somewhere. Don't rely on unplugging the idle bypass valve, you don't know what is actually happening...block the pipe
92 2.1SED M.RP5740 ECZ Sable Phenicien
92 3.0 V6-24.Rp 5713 EXY Black
92 2.1SD M.RP 5685 ENT Blue Sideral
Prev
90 2.1SD M.RP 5049 EJV Mandarin
92 2.1SD A.RP 5698 EJV Mandarin
94 2.1SD A.RP 6218 ERT Triton Green
91 2.0SI M.RP 5187 EWT White

User avatar
sageman
Knows how to use the parking brake
Posts: 117
Joined: Sat Sep 16, 2017 5:07 pm
Location: norwich

Re: sageman's 'barn find' v6 sei s1

Post by sageman » Thu May 16, 2019 7:56 pm

i will check again of course but i know blocking the bypass pipe brings the revs right down or stalls the engine
and my throttle plate/butterfly valve defiantly close properly

i diddnt know i had a lambda until recent forum readings that was another thing i was intending to try tomorrow

they dont raise slowly as the engine warm up but suddenly
it seems to me like the ECU is getting false information from somewhere and opening the ICV accordingly and im sure its running rich too....
1976 Reliant kitten
1985 Reliant fox Tandy campervan
1998 Peugeot 306 GTI-6
h̶o̶p̶e̶f̶u̶l̶l̶y̶ ̶a̶n̶ ̶X̶M̶ ̶o̶n̶e̶ ̶d̶a̶y̶
1993 XM sei V6

motorgnome
Knows how to use the parking brake
Posts: 140
Joined: Sun Aug 26, 2018 12:36 pm
Orga / RP numbers: Meteor Grey RP5058
Silver spares car RP4957

Re: sageman's 'barn find' v6 sei s1

Post by motorgnome » Fri May 17, 2019 3:00 am

Interestingly, the PRV 12 valve here in Australia doesn't run any Lambda sensors..It has a catalytic converter but no sensors or wiring for them. My 2 years older BX runs a lambda sensor though..Go figure..

Post Reply